What’s Vulnerable › Vulnerabilities
CVE-2017-10910
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-28 · updated 2026-06-17
- Weakness: CWE-674
Description
MQTT.js 2.x.x prior to 2.15.0 issue in handling PUBLISH tickets may lead to an attacker causing a denial-of-service condition.
Affected products
- MQTT.js. MQTT.js: from 2.0.0 before 2.15.0 — fixed in 2.15.0
How to fix
Upgrade to a fixed version: MQTT.js. MQTT.js 2.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/mqttjs/MQTT.js/commit/403ba53b838f2d319a0c0505a045fe00239e9923
- https://github.com/mqttjs/MQTT.js/releases/tag/v2.15.0
- https://jvn.jp/en/jp/JVN45494523/index.html
- https://github.com/mqttjs/MQTT.js/commit/403ba53b838f2d319a0c0505a045fe00239e9923
- https://github.com/mqttjs/MQTT.js/releases/tag/v2.15.0
- https://jvn.jp/en/jp/JVN45494523/index.html
Get alerted when CVE-2017-10910 or the next vulnerability affects your stack