What’s Vulnerable › Vulnerabilities
CVE-2017-10954
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-31 · updated 2026-06-17
- Weakness: CWE-190
Description
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Bitdefender Internet Security Internet Security 2018 prior to build 7.72918. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within pdf.xmd. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code under the context of SYSTEM. Was ZDI-CAN-4361.
Affected products
- Bitdefender Internet Security: before 7.72918 — fixed in 7.72918
How to fix
Upgrade to a fixed version: Bitdefender Internet Security 7.72918. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/100676
- https://zerodayinitiative.com/advisories/ZDI-17-717
- http://www.securityfocus.com/bid/100676
- https://zerodayinitiative.com/advisories/ZDI-17-717
Get alerted when CVE-2017-10954 or the next vulnerability affects your stack