What’s Vulnerable › Vulnerabilities
CVE-2017-10978
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-17 · updated 2026-06-17
- Weakness: CWE-119
Description
An FR-GV-201 issue in FreeRADIUS 2.x before 2.2.10 and 3.x before 3.0.15 allows "Read / write overflow in make_secret()" and a denial of service.
Affected products
- Debian Linux: 8.0, 9.0
- freeradius: from 2.0 before 2.2.10; from 3.0.0 before 3.0.15 — fixed in 2.2.10, 3.0.15
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Eus: 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.4, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: freeradius 2.2.10, 3.0.15. Check the vendor advisory for mitigations.
References
- http://freeradius.org/security/fuzzer-2017.html
- http://www.debian.org/security/2017/dsa-3930
- http://www.securityfocus.com/bid/99893
- http://www.securitytracker.com/id/1038914
- https://access.redhat.com/errata/RHSA-2017:1759
- https://access.redhat.com/errata/RHSA-2017:2389
- http://freeradius.org/security/fuzzer-2017.html
- http://www.debian.org/security/2017/dsa-3930
- http://www.securityfocus.com/bid/99893
- http://www.securitytracker.com/id/1038914
- https://access.redhat.com/errata/RHSA-2017:1759
- https://access.redhat.com/errata/RHSA-2017:2389
Get alerted when CVE-2017-10978 or the next vulnerability affects your stack