What’s Vulnerable › Vulnerabilities

CVE-2017-11147

Description

In PHP before 5.6.30 and 7.x before 7.0.15, the PHAR archive handler could be used by attackers supplying malicious archive files to crash the PHP interpreter or potentially disclose information due to a buffer over-read in the phar_parse_pharfile function in ext/phar/phar.c.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.6.30, 7.0.15, 7.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-11147 or the next vulnerability affects your stack