What’s Vulnerable › Vulnerabilities
CVE-2017-11352
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-17 · updated 2026-06-17
Description
In ImageMagick before 7.0.5-10, a crafted RLE image can trigger a crash because of incorrect EOF handling in coders/rle.c. NOTE: this vulnerability exists because of an incomplete fix for CVE-2017-9144.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 8.0
- ImageMagick: before 6.9.8-9; from 7.0.0-0 before 7.0.5-10 — fixed in 6.9.8-9, 7.0.5-10
How to fix
Upgrade to a fixed version: ImageMagick 6.9.8-9, 7.0.5-10. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/99600
- https://bugs.debian.org/868469
- https://github.com/ImageMagick/ImageMagick/issues/502
- https://usn.ubuntu.com/3681-1/
- https://www.debian.org/security/2017/dsa-4040
- http://www.securityfocus.com/bid/99600
- https://bugs.debian.org/868469
- https://github.com/ImageMagick/ImageMagick/issues/502
- https://usn.ubuntu.com/3681-1/
- https://www.debian.org/security/2017/dsa-4040
Get alerted when CVE-2017-11352 or the next vulnerability affects your stack