What’s Vulnerable › Vulnerabilities
CVE-2017-11422
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-24 · updated 2026-06-17
- Weakness: CWE-732
Description
Statamic framework before 2.6.0 does not correctly check a session's permissions when the methods from a user's class are called. Problematic methods include reset password, create new account, create new role, etc.
Affected products
- Statamic: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Statamic 2.6.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/rambo691/3714c8c09cf894d574d37c294711c49e
- https://gist.github.com/rambo691/3714c8c09cf894d574d37c294711c49e
Get alerted when CVE-2017-11422 or the next vulnerability affects your stack