What’s Vulnerable › Vulnerabilities
CVE-2017-11449
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-19 · updated 2026-06-17
Description
coders/mpc.c in ImageMagick before 7.0.6-1 does not enable seekable streams and thus cannot validate blob sizes, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via an image received from stdin.
Affected products
- ImageMagick: before 6.9.9-0; from 7.0.0-0 before 7.0.6-1 — fixed in 6.9.9-0, 7.0.6-1
How to fix
Upgrade to a fixed version: ImageMagick 6.9.9-0, 7.0.6-1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/99958
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=867896
- https://github.com/ImageMagick/ImageMagick/commit/529ff26b68febb2ac03062c58452ea0b4c6edbc1
- https://github.com/ImageMagick/ImageMagick/commit/b007dd3a048097d8f58949297f5b434612e1e1a3
- https://github.com/ImageMagick/ImageMagick/issues/556
- http://www.securityfocus.com/bid/99958
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=867896
- https://github.com/ImageMagick/ImageMagick/commit/529ff26b68febb2ac03062c58452ea0b4c6edbc1
- https://github.com/ImageMagick/ImageMagick/commit/b007dd3a048097d8f58949297f5b434612e1e1a3
- https://github.com/ImageMagick/ImageMagick/issues/556
Get alerted when CVE-2017-11449 or the next vulnerability affects your stack