What’s Vulnerable › Vulnerabilities
CVE-2017-11450
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-19 · updated 2026-06-17
Description
coders/jpeg.c in ImageMagick before 7.0.6-1 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via JPEG data that is too short.
Affected products
- Debian Linux: 9.0, 10.0
- ImageMagick: before 6.9.9-0; from 7.0.0-0 before 7.0.6-1 — fixed in 6.9.9-0, 7.0.6-1
How to fix
Upgrade to a fixed version: ImageMagick 6.9.9-0, 7.0.6-1. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=867894
- https://github.com/ImageMagick/ImageMagick/commit/948356eec65aea91995d4b7cc487d197d2c5f602
- https://github.com/ImageMagick/ImageMagick/issues/556
- https://security-tracker.debian.org/tracker/CVE-2017-11450
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=867894
- https://github.com/ImageMagick/ImageMagick/commit/948356eec65aea91995d4b7cc487d197d2c5f602
- https://github.com/ImageMagick/ImageMagick/issues/556
- https://security-tracker.debian.org/tracker/CVE-2017-11450
Get alerted when CVE-2017-11450 or the next vulnerability affects your stack