What’s Vulnerable › Vulnerabilities
CVE-2017-11480
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-08 · updated 2026-06-17
- Weakness: CWE-404
Description
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
Affected products
- Elastic Packetbeat: before 5.6.4 — fixed in 5.6.4
How to fix
Upgrade to a fixed version: Elastic Packetbeat 5.6.4. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/beats-5-6-4-security-update/106739
- https://discuss.elastic.co/t/beats-5-6-4-security-update/106739
Get alerted when CVE-2017-11480 or the next vulnerability affects your stack