What’s Vulnerable › Vulnerabilities
CVE-2017-11600
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-24 · updated 2026-06-17
- Weakness: CWE-125
Description
net/xfrm/xfrm_policy.c in the Linux kernel through 4.12.3, when CONFIG_XFRM_MIGRATE is enabled, does not ensure that the dir value of xfrm_userpolicy_id is XFRM_POLICY_MAX or less, which allows local users to cause a denial of service (out-of-bounds access) or possibly have unspecified other impact via an XFRM_MSG_MIGRATE xfrm Netlink message.
Affected products
- Linux kernel: from 2.6.21 before 3.2.93; from 3.3 before 3.10.108; from 3.11 before 3.18.70; from 3.19 before 4.1.45; from 4.2 before 4.4.87; from 4.5 before 4.9.48 — fixed in 3.10.108, 3.18.70, 3.2.93, 4.1.45, 4.12.11, 4.4.87
How to fix
Upgrade to a fixed version: Linux kernel 3.10.108, 3.18.70, 3.2.93, 4.1.45. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2018-01/msg00007.html
- http://seclists.org/bugtraq/2017/Jul/30
- http://www.debian.org/security/2017/dsa-3981
- http://www.securityfocus.com/bid/99928
- https://access.redhat.com/errata/RHSA-2018:1965
- https://access.redhat.com/errata/RHSA-2018:2003
- https://access.redhat.com/errata/RHSA-2019:1170
- https://access.redhat.com/errata/RHSA-2019:1190
- https://source.android.com/security/bulletin/pixel/2017-11-01
- http://lists.opensuse.org/opensuse-security-announce/2018-01/msg00007.html
- http://seclists.org/bugtraq/2017/Jul/30
- http://www.debian.org/security/2017/dsa-3981
Get alerted when CVE-2017-11600 or the next vulnerability affects your stack