What’s Vulnerable › Vulnerabilities
CVE-2017-12072
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in PixlrEditorHandler.php in Synology Photo Station before 6.8.0-3456 allows remote authenticated users to inject arbitrary web scripts or HTML via the id parameter.
Affected products
- Synology Photo Station: before 6.8.0-3456 — fixed in 6.8.0-3456
How to fix
Upgrade to a fixed version: Synology Photo Station 6.8.0-3456. Check the vendor advisory for mitigations.
References
- https://www.synology.com/en-global/support/security/Synology_SA_17_80
- https://www.synology.com/en-global/support/security/Synology_SA_17_80
Get alerted when CVE-2017-12072 or the next vulnerability affects your stack