What’s Vulnerable › Vulnerabilities

CVE-2017-12146

Description

The driver_override implementation in drivers/base/platform.c in the Linux kernel before 4.12.1 allows local users to gain privileges by leveraging a race condition between a read operation and a store operation that involve different overrides.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.18.61, 4.1.43, 4.11.10, 4.12.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-12146 or the next vulnerability affects your stack