What’s Vulnerable › Vulnerabilities
CVE-2017-12148
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in Ansible Tower's interface before 3.1.5 and 3.2.0 with SCM repositories. If a Tower project (SCM repository) definition does not have the 'delete before update' flag set, an attacker with commit access to the upstream playbook source repository could create a Trojan playbook that, when executed by Tower, modifies the checked out SCM repository to add git hooks. These git hooks could, in turn, cause arbitrary command and code execution as the user Tower runs as.
Affected products
- Tower: before 3.1.5; before 3.2.0 — fixed in 3.1.5, 3.2.0
- CloudForms: 4.5
How to fix
Upgrade to a fixed version: Tower 3.1.5, 3.2.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2017:3005
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-12148
- https://access.redhat.com/errata/RHSA-2017:3005
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-12148
Get alerted when CVE-2017-12148 or the next vulnerability affects your stack