What’s Vulnerable › Vulnerabilities
CVE-2017-12151
- Severity: high (CVSS 7.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-300
Description
A flaw was found in the way samba client before samba 4.4.16, samba 4.5.14 and samba 4.6.8 used encryption with the max protocol set as SMB3. The connection could lose the requirement for signing and encrypting to any DFS redirects, allowing an attacker to read or alter the contents of the connection via a man-in-the-middle attack.
Affected products
- Debian Linux: 8.0, 9.0
- HP Cifs Server: b.04.05.11.00
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server Aus: 7.4
- RedHat Enterprise Linux Server Eus: 7.4, 7.5
- RedHat Enterprise Linux Workstation: 7.0
- Samba: before 4.4.16; from 4.5.0 before 4.5.14; from 4.6.0 before 4.6.8 — fixed in 4.4.16, 4.5.14, 4.6.8
How to fix
Upgrade to a fixed version: Samba 4.4.16, 4.5.14, 4.6.8. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/100917
- http://www.securitytracker.com/id/1039401
- https://access.redhat.com/errata/RHSA-2017:2790
- https://access.redhat.com/errata/RHSA-2017:2858
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-12151
- https://security.netapp.com/advisory/ntap-20170921-0001/
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbux03817en_us
- https://www.debian.org/security/2017/dsa-3983
- https://www.samba.org/samba/security/CVE-2017-12151.html
- http://www.securityfocus.com/bid/100917
- http://www.securitytracker.com/id/1039401
- https://access.redhat.com/errata/RHSA-2017:2790
Get alerted when CVE-2017-12151 or the next vulnerability affects your stack