What’s Vulnerable › Vulnerabilities

CVE-2017-12165

Description

It was discovered that Undertow before 1.4.17, 1.3.31 and 2.0.0 processes http request headers with unusual whitespaces which can cause possible http request smuggling.

Affected products

How to fix

Upgrade to a fixed version: Red Hat undertow 1.3.31, 1.4.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-12165 or the next vulnerability affects your stack