What’s Vulnerable › Vulnerabilities
CVE-2017-12166
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-04 · updated 2026-06-17
- Weakness: CWE-787
Description
OpenVPN versions before 2.3.3 and 2.4.x before 2.4.4 are vulnerable to a buffer overflow vulnerability when key-method 1 is used, possibly resulting in code execution.
Affected products
- Debian Linux: 9.0
- OpenVPN: before 2.3.18; from 2.4.0 before 2.4.4 — fixed in 2.3.18, 2.4.4
How to fix
Upgrade to a fixed version: OpenVPN 2.3.18, 2.4.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101153
- http://www.securitytracker.com/id/1039470
- https://community.openvpn.net/openvpn/wiki/CVE-2017-12166
- https://lists.debian.org/debian-lts-announce/2022/05/msg00002.html
- http://www.securityfocus.com/bid/101153
- http://www.securitytracker.com/id/1039470
- https://community.openvpn.net/openvpn/wiki/CVE-2017-12166
- https://lists.debian.org/debian-lts-announce/2022/05/msg00002.html
Get alerted when CVE-2017-12166 or the next vulnerability affects your stack