What’s Vulnerable › Vulnerabilities
CVE-2017-12173
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-20
Description
It was found that sssd's sysdb_search_user_by_upn_res() function before 1.16.0 did not sanitize requests when querying its local cache and was vulnerable to injection. In a centralized login environment, if a password hash was locally cached for a given user, an authenticated attacker could use this flaw to retrieve it.
Affected products
- [UNKNOWN] sssd: before 1.16.0 — fixed in 1.16.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4
- RedHat Enterprise Linux Server Eus: 7.4, 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: [UNKNOWN] sssd 1.16.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2017:3379
- https://access.redhat.com/errata/RHSA-2018:1877
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-12173
- https://access.redhat.com/errata/RHSA-2017:3379
- https://access.redhat.com/errata/RHSA-2018:1877
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-12173
Get alerted when CVE-2017-12173 or the next vulnerability affects your stack