What’s Vulnerable › Vulnerabilities
CVE-2017-12178
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-24 · updated 2026-06-17
- Weakness: CWE-391
Description
xorg-x11-server before 1.19.5 had wrong extra length check in ProcXIChangeHierarchy function allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
Affected products
- Debian Linux: 8.0, 9.0
- xorg-x11-server: before 1.19.5 — fixed in 1.19.5
How to fix
Upgrade to a fixed version: xorg-x11-server 1.19.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1509219
- https://cgit.freedesktop.org/xorg/xserver/commit/?id=859b08d523307eebde7724fd1a0789c44813e821
- https://lists.debian.org/debian-lts-announce/2017/11/msg00032.html
- https://security.gentoo.org/glsa/201711-05
- https://www.debian.org/security/2017/dsa-4000
- https://bugzilla.redhat.com/show_bug.cgi?id=1509219
- https://cgit.freedesktop.org/xorg/xserver/commit/?id=859b08d523307eebde7724fd1a0789c44813e821
- https://lists.debian.org/debian-lts-announce/2017/11/msg00032.html
- https://security.gentoo.org/glsa/201711-05
- https://www.debian.org/security/2017/dsa-4000
Get alerted when CVE-2017-12178 or the next vulnerability affects your stack