What’s Vulnerable › Vulnerabilities

CVE-2017-12188

Description

arch/x86/kvm/mmu.c in the Linux kernel through 4.13.5, when nested virtualisation is used, does not properly traverse guest pagetable entries to resolve a guest virtual address, which allows L1 guest OS users to execute arbitrary code on the host OS or cause a denial of service (incorrect index during page walking, and host OS crash), aka an "MMU potential stack buffer overrun."

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.13.8, 4.9.57. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-12188 or the next vulnerability affects your stack