What’s Vulnerable › Vulnerabilities
CVE-2017-12424
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-04 · updated 2026-06-17
- Weakness: CWE-119
Description
In shadow before 4.5, the newusers tool could be made to manipulate internal data structures in ways unintended by the authors. Malformed input may lead to crashes (with a buffer overflow or other memory corruption) or other unspecified behaviors. This crosses a privilege boundary in, for example, certain web-hosting environments in which a Control Panel allows an unprivileged user account to create subaccounts.
Affected products
- Debian Linux: 9.0
- Shadow Project Shadow: before 4.5 — fixed in 4.5
How to fix
Upgrade to a fixed version: Shadow Project Shadow 4.5. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=756630
- https://bugs.launchpad.net/ubuntu/+source/shadow/+bug/1266675
- https://github.com/shadow-maint/shadow/commit/954e3d2e7113e9ac06632aee3c69b8d818cc8952
- https://lists.debian.org/debian-lts-announce/2021/03/msg00020.html
- https://security.gentoo.org/glsa/201710-16
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=756630
- https://bugs.launchpad.net/ubuntu/+source/shadow/+bug/1266675
- https://github.com/shadow-maint/shadow/commit/954e3d2e7113e9ac06632aee3c69b8d818cc8952
- https://lists.debian.org/debian-lts-announce/2021/03/msg00020.html
- https://security.gentoo.org/glsa/201710-16
Get alerted when CVE-2017-12424 or the next vulnerability affects your stack