What’s Vulnerable › Vulnerabilities
CVE-2017-12465
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-07 · updated 2026-06-17
- Weakness: CWE-190
Description
Multiple integer overflows in CCN-lite before 2.00 allow context-dependent attackers to have unspecified impact via vectors involving the (1) vallen variable in the iottlv_parse_sequence function or (2) typ, vallen and i variables in the localrpc_parse function.
Affected products
- Ccn-Lite: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Ccn-Lite 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/cn-uofbasel/ccn-lite/issues/131
- https://github.com/cn-uofbasel/ccn-lite/releases/tag/2.0.0
- https://github.com/cn-uofbasel/ccn-lite/issues/131
- https://github.com/cn-uofbasel/ccn-lite/releases/tag/2.0.0
Get alerted when CVE-2017-12465 or the next vulnerability affects your stack