What’s Vulnerable › Vulnerabilities
CVE-2017-12466
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-07 · updated 2026-06-17
- Weakness: CWE-119
Description
CCN-lite before 2.00 allows context-dependent attackers to have unspecified impact via vectors related to ssl_halen when running ccn-lite-sim, which trigger an out-of-bounds access.
Affected products
- Ccn-Lite: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Ccn-Lite 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/cn-uofbasel/ccn-lite/issues/132
- https://github.com/cn-uofbasel/ccn-lite/releases/tag/2.0.0
- https://github.com/cn-uofbasel/ccn-lite/issues/132
- https://github.com/cn-uofbasel/ccn-lite/releases/tag/2.0.0
Get alerted when CVE-2017-12466 or the next vulnerability affects your stack