What’s Vulnerable › Vulnerabilities
CVE-2017-12477
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 68.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-08-07 · updated 2026-06-17
- Weakness: CWE-287
Description
It was discovered that the bpserverd proprietary protocol in Unitrends Backup (UB) before 10.0.0, as invoked through xinetd, has an issue in which its authentication can be bypassed. A remote attacker could use this issue to execute arbitrary commands with root privilege on the target system.
Affected products
- Kaseya Unitrends Backup: before 10.0 — fixed in 10.0
How to fix
Upgrade to a fixed version: Kaseya Unitrends Backup 10.0. Check the vendor advisory for mitigations.
References
- https://support.unitrends.com/UnitrendsBackup/s/article/000005755
- https://www.exploit-db.com/exploits/43031/
- https://support.unitrends.com/UnitrendsBackup/s/article/000005755
- https://www.exploit-db.com/exploits/43031/
Get alerted when CVE-2017-12477 or the next vulnerability affects your stack