What’s Vulnerable › Vulnerabilities
CVE-2017-12607
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-20 · updated 2026-06-17
- Weakness: CWE-787
Description
A vulnerability in OpenOffice's PPT file parser before 4.1.4, and specifically in PPTStyleSheet, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.
Affected products
- Apache Software Foundation Apache OpenOffice: before 4.1.4 — fixed in 4.1.4
- Debian Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenOffice 4.1.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101585
- http://www.securitytracker.com/id/1039732
- http://www.securitytracker.com/id/1039734
- https://lists.debian.org/debian-lts-announce/2017/12/msg00017.html
- https://www.debian.org/security/2017/dsa-4022
- https://www.openoffice.org/security/cves/CVE-2017-12607.html
- http://www.securityfocus.com/bid/101585
- http://www.securitytracker.com/id/1039732
- http://www.securitytracker.com/id/1039734
- https://lists.debian.org/debian-lts-announce/2017/12/msg00017.html
- https://www.debian.org/security/2017/dsa-4022
- https://www.openoffice.org/security/cves/CVE-2017-12607.html
Get alerted when CVE-2017-12607 or the next vulnerability affects your stack