What’s Vulnerable › Vulnerabilities
CVE-2017-12622
- Severity: high (CVSS 7.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-10 · updated 2026-06-17
- Weakness: CWE-200
Description
When an Apache Geode cluster before v1.3.0 is operating in secure mode and an authenticated user connects to a Geode cluster using the gfsh tool with HTTP, the user is able to obtain status information and control cluster members even without CLUSTER:MANAGE privileges.
Affected products
- Apache Software Foundation Apache Geode: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Geode 1.3.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/560578479dabbdc93d0ee8746b7c857549202ef82f43aa22496aa589%40%3Cuser.geode.apache.org%3E
- https://lists.apache.org/thread.html/560578479dabbdc93d0ee8746b7c857549202ef82f43aa22496aa589%40%3Cuser.geode.apache.org%3E
Get alerted when CVE-2017-12622 or the next vulnerability affects your stack