What’s Vulnerable › Vulnerabilities
CVE-2017-12636
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 90.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-14 · updated 2026-06-17
- Weakness: CWE-78
Description
CouchDB administrative users can configure the database server via HTTP(S). Some of the configuration options include paths for operating system-level binaries that are subsequently launched by CouchDB. This allows an admin user in Apache CouchDB before 1.7.0 and 2.x before 2.1.1 to execute arbitrary shell commands as the CouchDB user, including downloading and executing scripts from the public internet.
Affected products
- Apache Software Foundation Apache CouchDB: before 1.7.0; 2.0.0, 2.0.0-rc1, 2.0.0-rc2, 2.0.0-rc3, 2.0.0-rc4 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CouchDB 1.7.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/6c405bf3f8358e6314076be9f48c89a2e0ddf00539906291ebdf0c67%40%3Cdev.couchdb.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2018/01/msg00026.html
- https://security.gentoo.org/glsa/201711-16
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbmu03935en_us
- https://www.exploit-db.com/exploits/44913/
- https://www.exploit-db.com/exploits/45019/
- https://lists.apache.org/thread.html/6c405bf3f8358e6314076be9f48c89a2e0ddf00539906291ebdf0c67%40%3Cdev.couchdb.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2018/01/msg00026.html
- https://security.gentoo.org/glsa/201711-16
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbmu03935en_us
- https://www.exploit-db.com/exploits/44913/
- https://www.exploit-db.com/exploits/45019/
Get alerted when CVE-2017-12636 or the next vulnerability affects your stack