What’s Vulnerable › Vulnerabilities
CVE-2017-12796
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-10-23 · updated 2026-06-17
- Weakness: CWE-502
Description
The Reporting Compatibility Add On before 2.0.4 for OpenMRS, as distributed in OpenMRS Reference Application before 2.6.1, does not authenticate users when deserializing XML input into ReportSchema objects. The result is that remote unauthenticated users are able to execute operating system commands by crafting malicious XML payloads, as demonstrated by a single admin/reports/reportSchemaXml.form request.
Affected products
- OpenMRS: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: OpenMRS 2.6.1. Check the vendor advisory for mitigations.
References
- https://isears.github.io/jekyll/update/2017/10/21/openmrs-rce.html
- https://talk.openmrs.org/t/critical-security-advisory-2017-09-12/13291
- https://wiki.openmrs.org/display/RES/Release+Notes+2.6.1
- https://isears.github.io/jekyll/update/2017/10/21/openmrs-rce.html
- https://talk.openmrs.org/t/critical-security-advisory-2017-09-12/13291
- https://wiki.openmrs.org/display/RES/Release+Notes+2.6.1
Get alerted when CVE-2017-12796 or the next vulnerability affects your stack