What’s Vulnerable › Vulnerabilities
CVE-2017-12876
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-28 · updated 2026-06-17
- Weakness: CWE-787
Description
Heap-based buffer overflow in enhance.c in ImageMagick before 7.0.6-6 allows remote attackers to cause a denial of service via a crafted file.
Affected products
- ImageMagick: from 7.0.0-0 before 7.0.6-6 — fixed in 7.0.6-6
How to fix
Upgrade to a fixed version: ImageMagick 7.0.6-6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/08/16/3
- https://blogs.gentoo.org/ago/2017/08/10/imagemagick-heap-based-buffer-overflow-in-omp_outlined-32-enhance-c/
- https://github.com/ImageMagick/ImageMagick/commit/1cc6f0ccc92c20c7cab6c4a7335daf29c91f0d8e
- https://security.gentoo.org/glsa/201711-07
- http://www.openwall.com/lists/oss-security/2017/08/16/3
- https://blogs.gentoo.org/ago/2017/08/10/imagemagick-heap-based-buffer-overflow-in-omp_outlined-32-enhance-c/
- https://github.com/ImageMagick/ImageMagick/commit/1cc6f0ccc92c20c7cab6c4a7335daf29c91f0d8e
- https://security.gentoo.org/glsa/201711-07
Get alerted when CVE-2017-12876 or the next vulnerability affects your stack