What’s Vulnerable › Vulnerabilities
CVE-2017-12945
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-27 · updated 2026-06-17
- Weakness: CWE-78
Description
Insufficient validation of user-supplied input for the Solstice Pod before 2.8.4 networking configuration enables authenticated attackers to execute arbitrary commands as root.
Affected products
- mersive Solstice Firmware: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: mersive Solstice Firmware 2.8.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/155494/Mersive-Solstice-2.8.0-Remote-Code-Execution.html
- https://documentation.mersive.com/content/pages/release-notes.htm
- https://github.com/aress31/cve-2017-12945
- https://www.exploit-db.com/exploits/47722
- http://packetstormsecurity.com/files/155494/Mersive-Solstice-2.8.0-Remote-Code-Execution.html
- https://documentation.mersive.com/content/pages/release-notes.htm
- https://github.com/aress31/cve-2017-12945
- https://www.exploit-db.com/exploits/47722
Get alerted when CVE-2017-12945 or the next vulnerability affects your stack