What’s Vulnerable › Vulnerabilities
CVE-2017-13769
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-30 · updated 2026-06-17
- Weakness: CWE-125
Description
The WriteTHUMBNAILImage function in coders/thumbnail.c in ImageMagick through 7.0.6-10 allows an attacker to cause a denial of service (buffer over-read) by sending a crafted JPEG file.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 8.0, 9.0
- ImageMagick: before 6.9.9-11; from 7.0.0-0 through 7.0.6-10 — fixed in 6.9.9-11
How to fix
Upgrade to a fixed version: ImageMagick 6.9.9-11. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/issues/705
- https://security.gentoo.org/glsa/201711-07
- https://usn.ubuntu.com/3681-1/
- https://www.debian.org/security/2017/dsa-4032
- https://www.debian.org/security/2017/dsa-4040
- https://github.com/ImageMagick/ImageMagick/issues/705
- https://security.gentoo.org/glsa/201711-07
- https://usn.ubuntu.com/3681-1/
- https://www.debian.org/security/2017/dsa-4032
- https://www.debian.org/security/2017/dsa-4040
Get alerted when CVE-2017-13769 or the next vulnerability affects your stack