What’s Vulnerable › Vulnerabilities
CVE-2017-14039
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-30 · updated 2026-06-17
- Weakness: CWE-787
Description
A heap-based buffer overflow was discovered in the opj_t2_encode_packet function in lib/openjp2/t2.c in OpenJPEG 2.2.0. The vulnerability causes an out-of-bounds write, which may lead to remote denial of service or possibly unspecified other impact.
Affected products
- Debian Linux: 8.0, 9.0
- uclouvain openjpeg: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: uclouvain openjpeg 2.3.0. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-4013
- http://www.securityfocus.com/bid/100550
- https://blogs.gentoo.org/ago/2017/08/28/openjpeg-heap-based-buffer-overflow-in-opj_t2_encode_packet-t2-c/
- https://github.com/uclouvain/openjpeg/commit/c535531f03369623b9b833ef41952c62257b507e
- https://github.com/uclouvain/openjpeg/issues/992
- https://security.gentoo.org/glsa/201710-26
- http://www.debian.org/security/2017/dsa-4013
- http://www.securityfocus.com/bid/100550
- https://blogs.gentoo.org/ago/2017/08/28/openjpeg-heap-based-buffer-overflow-in-opj_t2_encode_packet-t2-c/
- https://github.com/uclouvain/openjpeg/commit/c535531f03369623b9b833ef41952c62257b507e
- https://github.com/uclouvain/openjpeg/issues/992
- https://security.gentoo.org/glsa/201710-26
Get alerted when CVE-2017-14039 or the next vulnerability affects your stack