What’s Vulnerable › Vulnerabilities
CVE-2017-14062
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-31 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- GNU Libidn2: before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: GNU Libidn2 2.0.4. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3988
- https://gitlab.com/libidn/libidn2/blob/master/NEWS
- https://gitlab.com/libidn/libidn2/commit/3284eb342cd0ed1a18786e3fcdf0cdd7e76676bd
- https://lists.debian.org/debian-lts-announce/2018/07/msg00040.html
- http://www.debian.org/security/2017/dsa-3988
- https://gitlab.com/libidn/libidn2/blob/master/NEWS
- https://gitlab.com/libidn/libidn2/commit/3284eb342cd0ed1a18786e3fcdf0cdd7e76676bd
- https://lists.debian.org/debian-lts-announce/2018/07/msg00040.html
Get alerted when CVE-2017-14062 or the next vulnerability affects your stack