What’s Vulnerable › Vulnerabilities
CVE-2017-14107
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-09-01 · updated 2026-06-17
- Weakness: CWE-770
Description
The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.
Affected products
- Debian Linux: 9.0
- Libzip: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Libzip 1.3.0. Check the vendor advisory for mitigations.
References
- https://blogs.gentoo.org/ago/2017/09/01/libzip-memory-allocation-failure-in-_zip_cdir_grow-zip_dirent-c/
- https://github.com/nih-at/libzip/commit/9b46957ec98d85a572e9ef98301247f39338a3b5
- https://lists.debian.org/debian-lts-announce/2021/12/msg00022.html
- https://blogs.gentoo.org/ago/2017/09/01/libzip-memory-allocation-failure-in-_zip_cdir_grow-zip_dirent-c/
- https://github.com/nih-at/libzip/commit/9b46957ec98d85a572e9ef98301247f39338a3b5
- https://lists.debian.org/debian-lts-announce/2021/12/msg00022.html
Get alerted when CVE-2017-14107 or the next vulnerability affects your stack