What’s Vulnerable › Vulnerabilities
CVE-2017-14179
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-02 · updated 2026-06-17
- Weakness: CWE-400
Description
Apport before 2.13 does not properly handle crashes originating from a PID namespace allowing local users to create certain files as root which an attacker could leverage to perform a denial of service via resource exhaustion, possibly gain root privileges, or escape from containers.
Affected products
- Apport: before 2.13 — fixed in 2.13
- Canonical Ubuntu Linux: 14.04, 16.04, 17.04, 17.10, 18.04
How to fix
Upgrade to a fixed version: Apport 2.13. Check the vendor advisory for mitigations.
References
- https://launchpad.net/bugs/1726372
- https://people.canonical.com/~ubuntu-security/cve/?cve=CVE-2017-14179
- https://launchpad.net/bugs/1726372
- https://people.canonical.com/~ubuntu-security/cve/?cve=CVE-2017-14179
Get alerted when CVE-2017-14179 or the next vulnerability affects your stack