What’s Vulnerable › Vulnerabilities
CVE-2017-14202: The shell implementation does not protect against buffer overruns resulting in unpredictable behavior.
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-29 · updated 2026-06-17
- Weakness: CWE-119
Description
Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability in the shell component of Zephyr allows a serial or telnet connected user to cause a crash, possibly with arbitrary code execution. This issue affects: Zephyr shell versions prior to 1.14.0 on all.
Affected products
- zephyrproject zephyr: before 1.14.0 — fixed in 1.14.0
How to fix
Upgrade to a fixed version: zephyrproject zephyr 1.14.0. Check the vendor advisory for mitigations.
References
- https://docs.zephyrproject.org/1.14.0/releases/release-notes-1.14.html
- https://github.com/zephyrproject-rtos/zephyr/pull/13048
- https://zephyrprojectsec.atlassian.net/browse/ZEPSEC-18
- https://docs.zephyrproject.org/1.14.0/releases/release-notes-1.14.html
- https://github.com/zephyrproject-rtos/zephyr/pull/13048
- https://zephyrprojectsec.atlassian.net/browse/ZEPSEC-18
Get alerted when CVE-2017-14202 or the next vulnerability affects your stack