What’s Vulnerable › Vulnerabilities
CVE-2017-14386
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The web user interface of Dell 2335dn and 2355dn Multifunction Laser Printers, firmware versions prior to V2.70.06.26 A13 and V2.70.45.34 A10 respectively, are affected by a cross-site scripting vulnerability. Attackers could potentially exploit this vulnerability to execute arbitrary HTML or JavaScript code in the user's browser session in the context of the affected website.
Affected products
- Dell 2335Dn Firmware: before 2.70.06.26_a13 — fixed in 2.70.06.26_a13
- Dell 2355Dn Firmware: before 2.70.45.34_a10 — fixed in 2.70.45.34_a10
How to fix
Upgrade to a fixed version: Dell 2335Dn Firmware 2.70.06.26_a13; Dell 2355Dn Firmware 2.70.45.34_a10. Check the vendor advisory for mitigations.
References
- http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=782W3
- http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=CG55V
- http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=782W3
- http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=CG55V
Get alerted when CVE-2017-14386 or the next vulnerability affects your stack