What’s Vulnerable › Vulnerabilities
CVE-2017-14585
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-27 · updated 2026-06-17
- Weakness: CWE-918
Description
A Server Side Request Forgery (SSRF) vulnerability could lead to remote code execution for authenticated administrators. This issue was introduced in version 2.2.0 of Hipchat Server and version 3.0.0 of Hipchat Data Center. Versions of Hipchat Server starting with 2.2.0 and before 2.2.6 are affected by this vulnerability. Versions of Hipchat Data Center starting with 3.0.0 and before 3.1.0 are affected.
Affected products
- Atlassian Hipchat Data Center: from 3.0.0 before 3.1.0 — fixed in 3.1.0
- Atlassian Hipchat Server: from 2.2.0 before 2.2.6 — fixed in 2.2.6
How to fix
Upgrade to a fixed version: Atlassian Hipchat Data Center 3.1.0; Atlassian Hipchat Server 2.2.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101945
- https://confluence.atlassian.com/hc/hipchat-server-security-advisory-2017-11-22-939946293.html
- https://jira.atlassian.com/browse/HCPUB-3526
- http://www.securityfocus.com/bid/101945
- https://confluence.atlassian.com/hc/hipchat-server-security-advisory-2017-11-22-939946293.html
- https://jira.atlassian.com/browse/HCPUB-3526
Get alerted when CVE-2017-14585 or the next vulnerability affects your stack