What’s Vulnerable › Vulnerabilities
CVE-2017-14589
- Severity: critical (CVSS 9.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-13 · updated 2026-06-17
- Weakness: CWE-20
Description
It was possible for double OGNL evaluation in FreeMarker templates through Struts FreeMarker tags to occur. An attacker who has restricted administration rights to Bamboo or who hosts a website that a Bamboo administrator visits, is able to exploit this vulnerability to execute Java code of their choice on systems that run a vulnerable version of Bamboo. All versions of Bamboo before 6.1.6 (the fixed version for 6.1.x) and from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) are affected by this vulnerability.
Affected products
- Atlassian Bamboo: before 6.1.6; from 6.2.0 before 6.2.5 — fixed in 6.1.6, 6.2.5
How to fix
Upgrade to a fixed version: Atlassian Bamboo 6.1.6, 6.2.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102188
- https://confluence.atlassian.com/bamboo/bamboo-security-advisory-2017-12-13-939939816.html
- https://jira.atlassian.com/browse/BAM-18842
- http://www.securityfocus.com/bid/102188
- https://confluence.atlassian.com/bamboo/bamboo-security-advisory-2017-12-13-939939816.html
- https://jira.atlassian.com/browse/BAM-18842
Get alerted when CVE-2017-14589 or the next vulnerability affects your stack