What’s Vulnerable › Vulnerabilities
CVE-2017-14590
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-13 · updated 2026-06-17
Description
Bamboo did not check that the name of a branch in a Mercurial repository contained argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan that has a non-linked Mercurialrepository, create or edit a plan when there is at least one linked Mercurial repository that the attacker has permission to use, or commit to a Mercurial repository used by a Bamboo plan which has branch detection enabled can execute code of their choice on systems that run a vulnerable version of Bamboo Server. Versions of Bamboo starting with 2.7.0 before 6.1.6 (the fixed version for 6.1.x) and from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) are affected by this vulnerability.
Affected products
- Atlassian Bamboo: from 2.7.0 before 6.1.6; from 6.2.0 before 6.2.5 — fixed in 6.1.6, 6.2.5
How to fix
Upgrade to a fixed version: Atlassian Bamboo 6.1.6, 6.2.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102193
- https://confluence.atlassian.com/bamboo/bamboo-security-advisory-2017-12-13-939939816.html
- https://jira.atlassian.com/browse/BAM-18843
- http://www.securityfocus.com/bid/102193
- https://confluence.atlassian.com/bamboo/bamboo-security-advisory-2017-12-13-939939816.html
- https://jira.atlassian.com/browse/BAM-18843
Get alerted when CVE-2017-14590 or the next vulnerability affects your stack