What’s Vulnerable › Vulnerabilities
CVE-2017-14591
- Severity: critical (CVSS 9.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-29 · updated 2026-06-17
- Weakness: CWE-88
Description
Atlassian Fisheye and Crucible versions less than 4.4.3 and version 4.5.0 are vulnerable to argument injection through filenames in Mercurial repositories, allowing attackers to execute arbitrary code on a system running the impacted software.
Affected products
- Atlassian Crucible: before 4.4.3; 4.5.0 — fixed in 4.4.3
- Atlassian Fisheye: before 4.4.3; 4.5.0 — fixed in 4.4.3
How to fix
Upgrade to a fixed version: Atlassian Crucible 4.4.3; Atlassian Fisheye 4.4.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102194
- https://confluence.atlassian.com/x/plcGO
- http://www.securityfocus.com/bid/102194
- https://confluence.atlassian.com/x/plcGO
Get alerted when CVE-2017-14591 or the next vulnerability affects your stack