What’s Vulnerable › Vulnerabilities
CVE-2017-14798: local privilege escalation in SUSE postgresql init script
- Severity: high (CVSS 7.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-01 · updated 2026-06-17
- Weakness: CWE-61
Description
A race condition in the postgresql init script could be used by attackers able to access the postgresql account to escalate their privileges to root.
Affected products
- PostgreSQL: before 9.4-0.5.3.1 — fixed in 9.4-0.5.3.1
- SUSE Linux Enterprise: 11-sp3
How to fix
Upgrade to a fixed version: PostgreSQL 9.4-0.5.3.1. Check the vendor advisory for mitigations.
References
- http://lists.suse.com/pipermail/sle-security-updates/2017-November/003420.html
- https://bugzilla.suse.com/show_bug.cgi?id=1062722
- https://www.exploit-db.com/exploits/45184/
- https://www.suse.com/de-de/security/cve/CVE-2017-14798/
- http://lists.suse.com/pipermail/sle-security-updates/2017-November/003420.html
- https://bugzilla.suse.com/show_bug.cgi?id=1062722
- https://www.exploit-db.com/exploits/45184/
- https://www.suse.com/de-de/security/cve/CVE-2017-14798/
Get alerted when CVE-2017-14798 or the next vulnerability affects your stack