What’s Vulnerable › Vulnerabilities
CVE-2017-14868
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-30 · updated 2026-06-17
- Weakness: CWE-611
Description
Restlet Framework before 2.3.11, when using SimpleXMLProvider, allows remote attackers to access arbitrary files via an XXE attack in a REST API HTTP request. This affects use of the Jax-rs extension.
Affected products
- Restlet: before 2.3.11 — fixed in 2.3.11
How to fix
Upgrade to a fixed version: Restlet 2.3.11. Check the vendor advisory for mitigations.
References
- https://github.com/restlet/restlet-framework-java/issues/1286
- https://github.com/restlet/restlet-framework-java/wiki/XEE-security-enhancements
- https://lgtm.com/blog/restlet_CVE-2017-14868
- https://github.com/restlet/restlet-framework-java/issues/1286
- https://github.com/restlet/restlet-framework-java/wiki/XEE-security-enhancements
- https://lgtm.com/blog/restlet_CVE-2017-14868
Get alerted when CVE-2017-14868 or the next vulnerability affects your stack