What’s Vulnerable › Vulnerabilities

CVE-2017-14993

Description

OXID eShop Community Edition before 6.0.0 RC3 (development), 4.10.x before 4.10.6 (maintenance), and 4.9.x before 4.9.11 (legacy), Enterprise Edition before 6.0.0 RC3 (development), 5.2.x before 5.2.11 (legacy), and 5.3.x before 5.3.6 (maintenance), and Professional Edition before 6.0.0 RC3 (development), 4.9.x before 4.9.11 (legacy) and 4.10.x before 4.10.6 (maintenance) allow remote attackers to crawl specially crafted URLs (aka "forced browsing") in order to overflow the database of the shop and consequently make it stop working. Prerequisite: the shop allows rendering empty categories to the storefront via an admin option.

Affected products

How to fix

Upgrade to a fixed version: OXID-eSales Eshop 4.10.6, 4.9.11, 5.2.11, 5.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-14993 or the next vulnerability affects your stack