What’s Vulnerable › Vulnerabilities
CVE-2017-15105
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-23 · updated 2026-06-17
- Weakness: CWE-358
Description
A flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An improperly validated wildcard NSEC record could be used to prove the non-existence (NXDOMAIN answer) of an existing wildcard record, or trick unbound into accepting a NODATA proof.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0
- NLnet Labs Unbound: before 1.6.8 — fixed in 1.6.8
How to fix
Upgrade to a fixed version: NLnet Labs Unbound 1.6.8. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102817
- https://lists.debian.org/debian-lts-announce/2018/01/msg00039.html
- https://lists.debian.org/debian-lts-announce/2019/02/msg00022.html
- https://unbound.net/downloads/CVE-2017-15105.txt
- https://usn.ubuntu.com/3673-1/
- http://www.securityfocus.com/bid/102817
- https://lists.debian.org/debian-lts-announce/2018/01/msg00039.html
- https://lists.debian.org/debian-lts-announce/2019/02/msg00022.html
- https://unbound.net/downloads/CVE-2017-15105.txt
- https://usn.ubuntu.com/3673-1/
Get alerted when CVE-2017-15105 or the next vulnerability affects your stack