What’s Vulnerable › Vulnerabilities
CVE-2017-15111
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-20 · updated 2026-06-17
- Weakness: CWE-377
Description
keycloak-httpd-client-install versions before 0.8 insecurely creates temporary file allowing local attackers to overwrite other files via symbolic link.
Affected products
- jdennis keycloak-httpd-client-install: before 0.8 — fixed in 0.8
How to fix
Upgrade to a fixed version: jdennis keycloak-httpd-client-install 0.8. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:2137
- https://github.com/jdennis/keycloak-httpd-client-install/commit/07f26e213196936fb328ea0c1d5a66a09d8b5440
- https://access.redhat.com/errata/RHSA-2019:2137
- https://github.com/jdennis/keycloak-httpd-client-install/commit/07f26e213196936fb328ea0c1d5a66a09d8b5440
Get alerted when CVE-2017-15111 or the next vulnerability affects your stack