What’s Vulnerable › Vulnerabilities
CVE-2017-15112
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-20 · updated 2026-06-17
- Weakness: CWE-200
Description
keycloak-httpd-client-install versions before 0.8 allow users to insecurely pass password through command line, leaking it via command history and process info to other local users.
Affected products
- jdennis keycloak-httpd-client-install: before 0.8 — fixed in 0.8
How to fix
Upgrade to a fixed version: jdennis keycloak-httpd-client-install 0.8. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:2137
- https://github.com/jdennis/keycloak-httpd-client-install/commit/c3121b271abaaa1a76de2b9ae89dacde0105cd75
- https://access.redhat.com/errata/RHSA-2019:2137
- https://github.com/jdennis/keycloak-httpd-client-install/commit/c3121b271abaaa1a76de2b9ae89dacde0105cd75
Get alerted when CVE-2017-15112 or the next vulnerability affects your stack