What’s Vulnerable › Vulnerabilities
CVE-2017-15115
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-15 · updated 2026-06-17
- Weakness: CWE-416
Description
The sctp_do_peeloff function in net/sctp/socket.c in the Linux kernel before 4.14 does not check whether the intended netns is used in a peel-off action, which allows local users to cause a denial of service (use-after-free and system crash) or possibly have unspecified other impact via crafted system calls.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10
- Debian Linux: 7.0
- Linux kernel: before 3.2.96; from 3.3 before 3.16.51; from 3.17 before 3.18.84; from 3.19 before 4.1.47; from 4.2 before 4.4.100; from 4.5 before 4.9.65 — fixed in 3.16.51, 3.18.84, 3.2.96, 4.1.47, 4.13.16, 4.4.100
- SUSE Linux Enterprise Server: 11-sp4
How to fix
Upgrade to a fixed version: Linux kernel 3.16.51, 3.18.84, 3.2.96, 4.1.47. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=df80cd9b28b9ebaa284a41df611dbf3a2d05ca74
- http://lists.opensuse.org/opensuse-security-announce/2018-01/msg00007.html
- http://seclists.org/oss-sec/2017/q4/282
- http://www.securityfocus.com/bid/101877
- https://bugzilla.redhat.com/show_bug.cgi?id=1513345
- https://github.com/torvalds/linux/commit/df80cd9b28b9ebaa284a41df611dbf3a2d05ca74
- https://lists.debian.org/debian-lts-announce/2017/12/msg00004.html
- https://patchwork.ozlabs.org/patch/827077/
- https://source.android.com/security/bulletin/pixel/2018-04-01
- https://usn.ubuntu.com/3581-1/
- https://usn.ubuntu.com/3581-2/
- https://usn.ubuntu.com/3581-3/
Get alerted when CVE-2017-15115 or the next vulnerability affects your stack