What’s Vulnerable › Vulnerabilities
CVE-2017-15118
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability was found in NBD server implementation in qemu before 2.11 allowing a client to request an export name of size up to 4096 bytes, which in fact should be limited to 256 bytes, causing an out-of-bounds stack write in the qemu process. If NBD server requires TLS, the attacker cannot trigger the buffer overflow without first successfully negotiating TLS.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- QEMU: before 2.11 — fixed in 2.11
- Red Hat Enterprise Linux: 7.0
How to fix
Upgrade to a fixed version: QEMU 2.11. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/11/28/8
- http://www.securityfocus.com/bid/101975
- https://access.redhat.com/errata/RHSA-2018:1104
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-15118
- https://lists.gnu.org/archive/html/qemu-devel/2017-11/msg05045.html
- https://usn.ubuntu.com/3575-1/
- https://www.exploit-db.com/exploits/43194/
- http://www.openwall.com/lists/oss-security/2017/11/28/8
- http://www.securityfocus.com/bid/101975
- https://access.redhat.com/errata/RHSA-2018:1104
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-15118
- https://lists.gnu.org/archive/html/qemu-devel/2017-11/msg05045.html
Get alerted when CVE-2017-15118 or the next vulnerability affects your stack