What’s Vulnerable › Vulnerabilities
CVE-2017-15119
- Severity: high (CVSS 8.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-400
Description
The Network Block Device (NBD) server in Quick Emulator (QEMU) before 2.11 is vulnerable to a denial of service issue. It could occur if a client sent large option requests, making the server waste CPU time on reading up to 4GB per request. A client could use this flaw to keep the NBD server from serving other requests, resulting in DoS.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 9.0
- QEMU: before 2.11.0 — fixed in 2.11.0
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: QEMU 2.11.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/11/28/9
- http://www.securityfocus.com/bid/102011
- https://access.redhat.com/errata/RHSA-2018:1104
- https://access.redhat.com/errata/RHSA-2018:1113
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-15119
- https://lists.gnu.org/archive/html/qemu-devel/2017-11/msg05044.html
- https://usn.ubuntu.com/3575-1/
- https://www.debian.org/security/2018/dsa-4213
- http://www.openwall.com/lists/oss-security/2017/11/28/9
- http://www.securityfocus.com/bid/102011
- https://access.redhat.com/errata/RHSA-2018:1104
- https://access.redhat.com/errata/RHSA-2018:1113
Get alerted when CVE-2017-15119 or the next vulnerability affects your stack