What’s Vulnerable › Vulnerabilities
CVE-2017-15130
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-02 · updated 2026-06-17
- Weakness: CWE-400
Description
A denial of service flaw was found in dovecot before 2.2.34. An attacker able to generate random SNI server names could exploit TLS SNI configuration lookups, leading to excessive memory usage and the process to restart.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 8.0, 9.0
- dovecot: before 2.2.34 — fixed in 2.2.34
How to fix
Upgrade to a fixed version: dovecot 2.2.34. Check the vendor advisory for mitigations.
References
- http://seclists.org/oss-sec/2018/q1/205
- https://bugzilla.redhat.com/show_bug.cgi?id=1532356
- https://lists.debian.org/debian-lts-announce/2018/03/msg00036.html
- https://usn.ubuntu.com/3587-1/
- https://usn.ubuntu.com/3587-2/
- https://www.debian.org/security/2018/dsa-4130
- https://www.dovecot.org/list/dovecot-news/2018-February/000370.html
- http://seclists.org/oss-sec/2018/q1/205
- https://bugzilla.redhat.com/show_bug.cgi?id=1532356
- https://lists.debian.org/debian-lts-announce/2018/03/msg00036.html
- https://usn.ubuntu.com/3587-1/
- https://usn.ubuntu.com/3587-2/
Get alerted when CVE-2017-15130 or the next vulnerability affects your stack